Unofficial Skyrim Special Edition Patch

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Meshes
  • Assigned To
    Nico coiN
  • Operating System All
  • Severity Low
  • Priority Low
  • Reported Version Skyrim SE: Vanilla
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Unofficial Skyrim Special Edition Patch
Opened by BlackPete - May 16 2017
Last edited by Arthmoor - August 01 2017

FS#22426 - WRFarmhouseWindMill.nif: Windows disappear when approaching them


Reported on SSE Nexus (USSEP thread) (#3268):

Architecture\WhiteRun\WRBuildings\WRFarmhouseWindMill.nif

The windows on the Whiterun windmills will disappear as you approach them. It requires getting relatively close before they are no longer visible. This is not an issue in Classic Skyrim with USLEEP.

These were edited in v3.0.1 ( FS#18814 ) which may or may not be related to the problem. The person who reported this on the SE Nexus claimed that the issue doesn’t occur without the patch installed, but it’s entirely possible this could be due to some type of vanilla issue with the SE mesh too.

The windmill in the linked screenshot is at the Pelagia Farm. FormID = 0005CA6C.

Closed by  Arthmoor
August 01 2017 03:13 AM
Reason for closing:  Fixed
Additional comments about closing:  

Fixed for USSEP 4.0.8.

Nico coiN commented on July 29 2017 09:58 PM

I did it intentionally. Here's the explanation/reason :
'SLSF1_External_Emittance' flag removed in 'Shader Flags 1' in block 38 'BSLightingShaderProperty'. I interpreted it as a glow supposed to render an inside light at night, as for almost all regular buildings where people are supposed to live/have activities at night. However, windmills are 'open' buildings with no light source inside...
Restore at your will but I'd qualify it as 'not a bug' unless there's another issue (normals are not quite the sames as in the original mesh, but I don't think it can cause any issue).

Admin
Arthmoor commented on July 29 2017 10:18 PM

The problem isn't that the glass lights up or doesn't. I already tried to set the light back to normal but it didn't change anything. The problem is that if you walk up close enough to the windmill, the glass disappears entirely. That should not happen.

Nico coiN commented on July 30 2017 02:42 AM

Fix here. Mesh in Oldrim format. Redone in a different way and optimized.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing