Unofficial Fallout 4 Patch

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Actors
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Low
  • Reported Version Fallout 4: Vanilla
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Unofficial Fallout 4 Patch
Opened by Sclerocephalus - April 16 2017
Last edited by Sclerocephalus - June 12 2017

FS#22341 - Level 06 Minutemen have wrong health values

This is a list of the minutemen’s health values and levels:

EncMinuteman01 Lvl 01 Health: -10
EncMinuteman02 Lvl 08 Health: 30
EncMinuteman03 Lvl 16 Health: 60
EncMinuteman04 Lvl 24 Health: 160
EncMinuteman05 Lvl 32 Health: 285
EncMinuteman06 Lvl 42 Health: 510
EncMinuteman07 Lvl 52 Health: 510
EncMinuteman08 Lvl 62 Health: 610

Something is obviously wrong because there shouldn’t be two levels with the same health value, and it appears that the value for lvl 06 is in fact too high.

I’m unable to suggest a proper value though, as there is no clear relationship between health and level.

Closed by  Sclerocephalus
June 12 2017 12:40 PM
Reason for closing:  Not A Bug
Additional comments about closing:  

See comments.

commented on April 16 2017 01:36 PM

the relationship between health and level is the amount of endurance points

afaik every npc have a s.p.e.c.i.a.l value, yes? then they should get the amount of HP based on endurance and level

MadCat221 commented on April 16 2017 02:04 PM

That's not the only factor in HP for NPCs. There are other more direct modifiers available on the Actor forms to control HP amount.

Sclerocephalus commented on April 16 2017 06:02 PM

The endurance formula is only for the player character. SPECIAL values of NPCs are usually not level-dependent. More specifically, the endurance of all minutemen is zero, irrespective of their level. Unless the engine creates level-dependent values fo them at run time (I have my doubts though that this happens).

Sclerocephalus commented on April 18 2017 11:22 AM

Update: I overlooked that the stats for level 1-6 minutemen are templated on level 1-6 raiders. This means that the health values for levels 7 and 8 (there are no corresponding raiders at those levels) are apparently too low.

Admin
Arthmoor commented on May 11 2017 08:45 PM

In looking at this in the CK, EncMinuteman07 uses stats templated from EncGunner05, and EncMinuteman08 uses stats templated from EncGunner06. This results in the CK saying that 07 has 660 calculated health, and 08 has 780.

Not really sure where the problem is supposed to be.

Sclerocephalus commented on June 12 2017 12:40 PM

Apparently not a bug then.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing