Unofficial Skyrim Legendary Edition Patch

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Quests
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Skyrim LE: Vanilla
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Unofficial Skyrim Legendary Edition Patch
Opened by Dwarfmp - March 11 2017
Last edited by Arthmoor - July 15 2017

FS#22119 - Laelette's and Thonnir's behavior during Laid to Rest

Through my new playthrough in SE, I noticed a few things. Originally, Laelette was present and invisible close to the graveyard. I don’t know if this was an official or unofficial fix, I know she was bugged at the release of the game, but that’s beside the point.

At this point, she was present when you had to find Helgi at night and talk to her coffin. Laelette behaved like a bandit, drawing her weapon as you got close, telling you to “back off”. This, instead of her showing up after talking to Helgi’s coffin. Now there’s no easy way to talk to Helgi’s coffin without Laelette turning hostile, and I don’t think this is how the quest was intended.

This while Thonnir stands still outside in town, clearly waiting for you to kill Laelette, as he’s normally not outside at night. When you do kill Laelette, he will immediately start to run to the scene, and does his usual dialogue: he notices Laelette, gets close and yell “Ye gods, she’s a vampire!” However, he seems to do this over and over, backing off the corpse and noticing her again. This until you either speak to the coffin, or him to progress the quest, which is more than humorous and immersion-breaking. Ideally, you should be able to speak to Helgi’s coffin, and when she’s finished talking, see Thonnir do his scene, if this is possible.

Closed by  Arthmoor
July 15 2017 02:00 AM
Reason for closing:  Cannot Reproduce
BlackPete commented on April 04 2017 03:16 AM

We're going to need saves to be provided to reproduce these. Otherwise, there's probably nothing we can do.

Admin
Arthmoor commented on July 15 2017 02:00 AM

Nothing wrong with this encounter. I just did this quest and Laelette behaved just as one would expect after speaking to Helgi's coffin.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing