Unofficial Skyrim Legendary Edition Patch

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Audio
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Skyrim LE: Hearthfire DLC
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Unofficial Skyrim Legendary Edition Patch
Opened by Campbell Grier - February 26 2017
Last edited by BlackPete - July 20 2017

FS#22077 - Ambient music doesn't stop when bard performs in HF homes - sounds like cacophony

When a purchased bard performs within any Hearthfire player home, the background ambient music continues to play, resulting in a complete cacophony of noise. This is not true in taverns where the background music fades to silent as soon as a bard starts to perform and then resumes whenever the bard stops playing. My preliminary research lead me to the BardSongsScript which has the function StopInnMusic() that replaces the current ambient music with a silent track - MUSTavernSilence. Note that the function is specific to LocTypeInn:

Function StopInnMusic()

	Game.GetPlayer().GetCurrentLocation().HasKeyword(LocTypeInn)
	MUSTavernSilence.Add()

EndFunction

Adding a property assigned to LocTypePlayerHouse and second line to the function that targets LocTypePlayerHouse partially solves the problem:

Game.GetPlayer().GetCurrentLocation().HasKeyword(LocTypePlayerHouse)

	MUSTavernSilence.Add()

With this fix the ambient music does stop when the bard performs in your player home. However, the ambient music does not resume when the bard stops playing, as it does in a tavern. Even after exiting and re-entering the house I could not get the ambient music to resume. There is clearly a second half to this puzzle which I am missing.

Closed by  BlackPete
July 20 2017 04:21 AM
Reason for closing:  Cannot Reproduce
Additional comments about closing:  

No followup has been provided.

Admin
Arthmoor commented on April 01 2017 12:07 AM

Have you tried leaving the property entirely? Like, say, from Heljarchen Hall go down to Loreius Farm and come back? The music removal is handled by a change location event which may not be firing until you've left the property entirely. Simply going outside might not be enough.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing