Unofficial Fallout 4 Patch

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Actors
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Fallout 4: Vanilla
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Unofficial Fallout 4 Patch
Opened by Ryan - January 09 2017
Last edited by Arthmoor - May 09 2017

FS#21854 - Curie NPC returned as male in Papyrus

With her set as a Ref and running this code:

HerRef.GetActorBase().GetSex()

It returns her as a Male when in the game she is a female synth

Closed by  Arthmoor
May 09 2017 08:41 PM
Reason for closing:  Fixed
Additional comments about closing:  

Fixed for UFO4P 2.0.1.

Admin
Arthmoor commented on January 18 2017 04:32 AM

I'm going to need to know which version of Curie you're doing this with as there are several.

MadCat221 commented on March 11 2017 07:42 AM

I wonder... does Robo-Curie return a Male report?

Try in the command line console, Ryan. Select Curie, and then enter the console command "GetIsSex Female" and see what it reports. I'm going to try on Robo-Curie to see what it returns.

EDIT: It seems that Robo-Curie returns =1 on "GetIsSex Male" and =0 on "GetIsSex Female".

EDIT 2: Okay... not sure if this will trickle down to Synth Curie, but Robo-Curie can be corrected. On the actor form EncCurieRobot (ID:001846CB), she is not checked as female. Checking as female will be reflected immediately for Robo-Curie, but my current (and first) playthru is not far along enough for her to be Synthed to test there. I will continue to play without the temp-fix to get to a state where I can test.

Ryan commented on May 02 2017 01:19 AM

Sorry for very late reply, when currie is a synth so when she looks like a female NPC she does not return as being female.
MadCat seems to be reproducing my findings and may be onto something regarding checking her as female as a fix

Admin
Arthmoor commented on May 09 2017 08:41 PM

EncCurieRobot definitely needed correction because Curie's template can choose stats from either the robot form or the synth form and if she chooses robot form the gender checks that come back are wrong.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing